What’s Vulnerable › Vulnerabilities
CVE-2015-2559
- Severity: low (CVSS 3.5 v2.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2015-03-25 · updated 2026-06-17
- Weakness: CWE-284
Description
Drupal 6.x before 6.35 and 7.x before 7.35 allows remote authenticated users to reset the password of other accounts by leveraging an account with the same password hash as another account and a crafted password reset URL.
Affected products
- Debian Linux: 7.0
- Drupal: from 6.0 before 6.35; from 7.0 before 7.35 — fixed in 6.35, 7.35
How to fix
Upgrade to a fixed version: Drupal 6.35, 7.35. Check the vendor advisory for mitigations.
References
- http://www.debian.org/security/2015/dsa-3200
- http://www.securityfocus.com/bid/73219
- https://www.drupal.org/SA-CORE-2015-001
- http://www.debian.org/security/2015/dsa-3200
- http://www.securityfocus.com/bid/73219
- https://www.drupal.org/SA-CORE-2015-001
Get alerted when CVE-2015-2559 or the next vulnerability affects your stack