What’s Vulnerable › Vulnerabilities
CVE-2015-2573
- Severity: medium (CVSS 4.0 v2.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 5.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2015-04-16 · updated 2026-06-17
Description
Unspecified vulnerability in Oracle MySQL Server 5.5.41 and earlier, and 5.6.22 and earlier, allows remote authenticated users to affect availability via vectors related to DDL.
Affected products
- Canonical Ubuntu Linux: 12.04, 14.04, 14.10
- Debian Linux: 7.0, 8.0
- MariaDB: from 5.5.0 before 5.5.42; from 10.0.0 before 10.0.17 — fixed in 10.0.17, 5.5.42
- MySQL Server: from 5.5.0 through 5.5.41; from 5.6.0 through 5.6.22
- Oracle Corporation Solaris Operating System: 11.3
- RedHat Enterprise Linux Desktop: 5.0, 7.0
- RedHat Enterprise Linux Eus: 7.1, 7.2, 7.3, 7.4, 7.5, 7.6 (+1)
- RedHat Enterprise Linux Server: 5.0, 7.0
- RedHat Enterprise Linux Server Aus: 7.3, 7.4, 7.6, 7.7
- RedHat Enterprise Linux Server Tus: 7.3, 7.6, 7.7
- RedHat Enterprise Linux Workstation: 5.0, 7.0
- SUSE Linux Enterprise Server 15 SP1: 11-sp3
- SUSE Linux Enterprise Server: 11-sp3
- SUSE Linux Enterprise Software Development Kit: 11-sp3
How to fix
Upgrade to a fixed version: MariaDB 10.0.17, 5.5.42. Check the vendor advisory for mitigations.
References
- http://lists.opensuse.org/opensuse-security-announce/2015-05/msg00026.html
- http://rhn.redhat.com/errata/RHSA-2015-1628.html
- http://rhn.redhat.com/errata/RHSA-2015-1629.html
- http://rhn.redhat.com/errata/RHSA-2015-1647.html
- http://rhn.redhat.com/errata/RHSA-2015-1665.html
- http://www.debian.org/security/2015/dsa-3229
- http://www.debian.org/security/2015/dsa-3311
- http://www.oracle.com/technetwork/topics/security/bulletinapr2016-2952098.html
- http://www.oracle.com/technetwork/topics/security/bulletinoct2015-2511968.html
- http://www.oracle.com/technetwork/topics/security/cpuapr2015-2365600.html
- http://www.securityfocus.com/bid/74078
- http://www.securitytracker.com/id/1032121
Get alerted when CVE-2015-2573 or the next vulnerability affects your stack