What’s Vulnerable › Vulnerabilities

CVE-2015-2666

Description

Stack-based buffer overflow in the get_matching_model_microcode function in arch/x86/kernel/cpu/microcode/intel_early.c in the Linux kernel before 4.0 allows context-dependent attackers to gain privileges by constructing a crafted microcode header and leveraging root privileges for write access to the initrd.

Affected products

How to fix

Upgrade to a fixed version: Linux kernel 3.10.83, 3.12.40, 3.14.47, 3.16.35. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2015-2666 or the next vulnerability affects your stack