What’s Vulnerable › Vulnerabilities
CVE-2015-2695
- Severity: medium (CVSS 5.0 v2.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 6.0% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2015-11-09 · updated 2026-06-17
- Weakness: CWE-763
Description
lib/gssapi/spnego/spnego_mech.c in MIT Kerberos 5 (aka krb5) before 1.14 relies on an inappropriate context handle, which allows remote attackers to cause a denial of service (incorrect pointer read and process crash) via a crafted SPNEGO packet that is mishandled during a gss_inquire_context call.
Affected products
- Canonical Ubuntu Linux: 12.04, 14.04, 15.04, 15.10
- Debian Linux: 7.0, 8.0, 9.0
- MIT Kerberos 5: before 1.14 — fixed in 1.14
- openSUSE Leap: 42.1
- Opensuse: 13.1, 13.2
- Oracle Corporation Solaris Operating System: 11.3
- SUSE Linux Enterprise Server 15 SP1: 11-sp3, 11-sp4, 12
- SUSE Linux Enterprise Server: 11-sp3, 11-sp4, 12
- SUSE Linux Enterprise Software Development Kit: 11-sp3, 11-sp4, 12
How to fix
Upgrade to a fixed version: MIT Kerberos 5 1.14. Check the vendor advisory for mitigations.
References
- http://krbdev.mit.edu/rt/Ticket/Display.html?id=8244
- http://lists.opensuse.org/opensuse-security-announce/2015-11/msg00006.html
- http://lists.opensuse.org/opensuse-security-announce/2015-11/msg00007.html
- http://lists.opensuse.org/opensuse-security-announce/2015-11/msg00014.html
- http://lists.opensuse.org/opensuse-security-announce/2015-11/msg00022.html
- http://www.debian.org/security/2015/dsa-3395
- http://www.oracle.com/technetwork/topics/security/bulletinapr2016-2952098.html
- http://www.securityfocus.com/bid/90687
- http://www.securitytracker.com/id/1034084
- http://www.ubuntu.com/usn/USN-2810-1
- https://github.com/krb5/krb5/commit/b51b33f2bc5d1497ddf5bd107f791c101695000d
- https://security.gentoo.org/glsa/201611-14
Get alerted when CVE-2015-2695 or the next vulnerability affects your stack