What’s Vulnerable › Vulnerabilities
CVE-2015-2696
- Severity: high (CVSS 7.1 v2.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 4.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2015-11-09 · updated 2026-06-17
- Weakness: CWE-18
Description
lib/gssapi/krb5/iakerb.c in MIT Kerberos 5 (aka krb5) before 1.14 relies on an inappropriate context handle, which allows remote attackers to cause a denial of service (incorrect pointer read and process crash) via a crafted IAKERB packet that is mishandled during a gss_inquire_context call.
Affected products
- Canonical Ubuntu Linux: 12.04, 14.04, 15.04, 15.10
- Debian Linux: 7.0, 8.0, 9.0
- MIT Kerberos 5: before 1.14 — fixed in 1.14
- openSUSE Leap: 42.1
- Opensuse: 13.1, 13.2
- SUSE Linux Enterprise Server 15 SP1: 12
- SUSE Linux Enterprise Server: 12
- SUSE Linux Enterprise Software Development Kit: 12
How to fix
Upgrade to a fixed version: MIT Kerberos 5 1.14. Check the vendor advisory for mitigations.
References
- http://krbdev.mit.edu/rt/Ticket/Display.html?id=8244
- http://lists.opensuse.org/opensuse-security-announce/2015-11/msg00006.html
- http://lists.opensuse.org/opensuse-security-announce/2015-11/msg00014.html
- http://lists.opensuse.org/opensuse-security-announce/2015-11/msg00022.html
- http://www.debian.org/security/2015/dsa-3395
- http://www.securityfocus.com/bid/90675
- http://www.securitytracker.com/id/1034084
- http://www.ubuntu.com/usn/USN-2810-1
- https://github.com/krb5/krb5/commit/e04f0283516e80d2f93366e0d479d13c9b5c8c2a
- https://security.gentoo.org/glsa/201611-14
- http://krbdev.mit.edu/rt/Ticket/Display.html?id=8244
- http://lists.opensuse.org/opensuse-security-announce/2015-11/msg00006.html
Get alerted when CVE-2015-2696 or the next vulnerability affects your stack