What’s Vulnerable › Vulnerabilities
CVE-2015-2793
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.7% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2019-11-21 · updated 2026-06-17
- Weakness: CWE-79
Description
Cross-site scripting (XSS) vulnerability in templates/openid-selector.tmpl in ikiwiki before 3.20150329 allows remote attackers to inject arbitrary web script or HTML via the openid_identifier parameter in a verify action to ikiwiki.cgi.
Affected products
- Fedoraproject Fedora: 20, 21, 22
- ikiwiki: before 3.20150329 — fixed in 3.20150329
How to fix
Upgrade to a fixed version: ikiwiki 3.20150329. Check the vendor advisory for mitigations.
References
- http://lists.fedoraproject.org/pipermail/package-announce/2015-May/157001.html
- http://lists.fedoraproject.org/pipermail/package-announce/2015-May/157023.html
- http://lists.fedoraproject.org/pipermail/package-announce/2015-May/157025.html
- http://openwall.com/lists/oss-security/2015/03/30/5
- http://openwall.com/lists/oss-security/2015/03/31/1
- http://source.ikiwiki.branchable.com/?p=source.git%3Ba=commitdiff%3Bh=18dfba868fe2fb9c64706b2123eb0b3a3ce66a77
- https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=781483
- https://bugzilla.redhat.com/show_bug.cgi?id=1207210
- https://ikiwiki.info/bugs/XSS_Alert...__33____33____33__/
- http://lists.fedoraproject.org/pipermail/package-announce/2015-May/157001.html
- http://lists.fedoraproject.org/pipermail/package-announce/2015-May/157023.html
- http://lists.fedoraproject.org/pipermail/package-announce/2015-May/157025.html
Get alerted when CVE-2015-2793 or the next vulnerability affects your stack