What’s Vulnerable › Vulnerabilities
CVE-2015-2992
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 5.8% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2020-02-27 · updated 2026-06-17
- Weakness: CWE-79
Description
Apache Struts before 2.3.20 has a cross-site scripting (XSS) vulnerability.
Affected products
- Apache Struts: from 2.0.0 before 2.3.20 — fixed in 2.3.20
How to fix
Upgrade to a fixed version: Apache Struts 2.3.20. Check the vendor advisory for mitigations.
References
- http://jvn.jp/en/jp/JVN88408929/index.html
- http://jvndb.jvn.jp/en/contents/2015/JVNDB-2015-000124.html
- http://www.securityfocus.com/bid/76624
- https://security.netapp.com/advisory/ntap-20200330-0001/
- http://jvn.jp/en/jp/JVN88408929/index.html
- http://jvndb.jvn.jp/en/contents/2015/JVNDB-2015-000124.html
- http://www.securityfocus.com/bid/76624
- https://security.netapp.com/advisory/ntap-20200330-0001/
Get alerted when CVE-2015-2992 or the next vulnerability affects your stack