What’s Vulnerable › Vulnerabilities

CVE-2015-3152

Description

Oracle MySQL before 5.7.3, Oracle MySQL Connector/C (aka libmysqlclient) before 6.1.3, and MariaDB before 5.5.44 use the --ssl option to mean that SSL is optional, which allows man-in-the-middle attackers to spoof servers via a cleartext-downgrade attack, aka a "BACKRONYM" attack.

Affected products

How to fix

Upgrade to a fixed version: MariaDB 10.0.20, 5.5.44; PHP 5.4.43, 5.5.27, 5.6.11. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2015-3152 or the next vulnerability affects your stack