What’s Vulnerable › Vulnerabilities
CVE-2015-3167
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 4.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2019-11-20 · updated 2026-06-17
- Weakness: CWE-200
Description
contrib/pgcrypto in PostgreSQL before 9.0.20, 9.1.x before 9.1.16, 9.2.x before 9.2.11, 9.3.x before 9.3.7, and 9.4.x before 9.4.2 uses different error responses when an incorrect key is used, which makes it easier for attackers to obtain the key via a brute force attack.
Affected products
- Canonical Ubuntu Linux: 12.04, 14.04, 14.10, 15.04
- Debian Linux: 7.0, 8.0, 9.0
- PostgreSQL: before 9.0.20; from 9.1 before 9.1.16; from 9.2 before 9.2.11; from 9.3 before 9.3.7; from 9.4 before 9.4.2 — fixed in 9.0.20, 9.1.16, 9.2.11, 9.3.7, 9.4.2
How to fix
Upgrade to a fixed version: PostgreSQL 9.0.20, 9.1.16, 9.2.11, 9.3.7. Check the vendor advisory for mitigations.
References
- http://ubuntu.com/usn/usn-2621-1
- http://www.debian.org/security/2015/dsa-3269
- http://www.debian.org/security/2015/dsa-3270
- http://www.postgresql.org/about/news/1587/
- http://www.postgresql.org/docs/9.0/static/release-9-0-20.html
- http://www.postgresql.org/docs/9.1/static/release-9-1-16.html
- http://www.postgresql.org/docs/9.2/static/release-9-2-11.html
- http://www.postgresql.org/docs/9.3/static/release-9-3-7.html
- http://www.postgresql.org/docs/9.4/static/release-9-4-2.html
- http://ubuntu.com/usn/usn-2621-1
- http://www.debian.org/security/2015/dsa-3269
- http://www.debian.org/security/2015/dsa-3270
Get alerted when CVE-2015-3167 or the next vulnerability affects your stack