What’s Vulnerable › Vulnerabilities

CVE-2015-3183

Description

The chunked transfer coding implementation in the Apache HTTP Server before 2.4.14 does not properly parse chunk headers, which allows remote attackers to conduct HTTP request smuggling attacks via a crafted request, related to mishandling of large chunk-size values and invalid chunk-extension characters in modules/http/http_filters.c.

Affected products

How to fix

Upgrade to a fixed version: Apache HTTP Server 2.2.31, 2.4.16. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2015-3183 or the next vulnerability affects your stack