What’s Vulnerable › Vulnerabilities
CVE-2015-3193
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 25.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2015-12-06 · updated 2026-06-17
- Weakness: CWE-200
Description
The Montgomery squaring implementation in crypto/bn/asm/x86_64-mont5.pl in OpenSSL 1.0.2 before 1.0.2e on the x86_64 platform, as used by the BN_mod_exp function, mishandles carry propagation and produces incorrect output, which makes it easier for remote attackers to obtain sensitive private-key information via an attack against use of a (1) Diffie-Hellman (DH) or (2) Diffie-Hellman Ephemeral (DHE) ciphersuite.
Affected products
- Canonical Ubuntu Linux: 12.04, 14.04, 15.04, 15.10
- Node.js: from 4.0.0 through 4.1.2; from 4.2.0 before 4.2.3; from 5.0.0 before 5.1.1 — fixed in 4.2.3, 5.1.1
- OpenSSL: 1.0.2, 1.0.2a, 1.0.2b, 1.0.2c, 1.0.2d
How to fix
Upgrade to a fixed version: Node.js 4.2.3, 5.1.1. Check the vendor advisory for mitigations.
References
- http://fortiguard.com/advisory/openssl-advisory-december-2015
- http://kb.juniper.net/InfoCenter/index?page=content&id=JSA10759
- http://kb.juniper.net/InfoCenter/index?page=content&id=JSA10761
- http://openssl.org/news/secadv/20151203.txt
- http://tools.cisco.com/security/center/content/CiscoSecurityAdvisory/cisco-sa-20151204-openssl
- http://www.fortiguard.com/advisory/openssl-advisory-december-2015
- http://www.oracle.com/technetwork/security-advisory/cpuapr2016v3-2985753.html
- http://www.oracle.com/technetwork/security-advisory/cpujul2016-2881720.html
- http://www.oracle.com/technetwork/security-advisory/cpuoct2017-3236626.html
- http://www.securityfocus.com/bid/78705
- http://www.securityfocus.com/bid/91787
- http://www.securitytracker.com/id/1034294
Get alerted when CVE-2015-3193 or the next vulnerability affects your stack