What’s Vulnerable › Vulnerabilities
CVE-2015-3194
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 44.0% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2015-12-06 · updated 2026-06-17
- Weakness: CWE-476
Description
crypto/rsa/rsa_ameth.c in OpenSSL 1.0.1 before 1.0.1q and 1.0.2 before 1.0.2e allows remote attackers to cause a denial of service (NULL pointer dereference and application crash) via an RSA PSS ASN.1 signature that lacks a mask generation function parameter.
Affected products
- Canonical Ubuntu Linux: 12.04, 14.04, 15.04, 15.10
- Debian Linux: 7.0, 8.0
- Node.js: from 0.10.0 before 0.10.41; from 0.12.0 before 0.12.9; from 4.0.0 before 4.2.3; from 5.0.0 before 5.1.1 — fixed in 0.10.41, 0.12.9, 4.2.3, 5.1.1
- OpenSSL: 1.0.1, 1.0.1a, 1.0.1b, 1.0.1c, 1.0.1d, 1.0.1e (+16)
How to fix
Upgrade to a fixed version: Node.js 0.10.41, 0.12.9, 4.2.3, 5.1.1. Check the vendor advisory for mitigations.
References
- http://fortiguard.com/advisory/openssl-advisory-december-2015
- http://kb.juniper.net/InfoCenter/index?page=content&id=JSA10759
- http://kb.juniper.net/InfoCenter/index?page=content&id=JSA10761
- http://lists.fedoraproject.org/pipermail/package-announce/2015-December/173801.html
- http://lists.opensuse.org/opensuse-security-announce/2016-03/msg00009.html
- http://lists.opensuse.org/opensuse-security-announce/2016-05/msg00053.html
- http://lists.opensuse.org/opensuse-updates/2015-12/msg00070.html
- http://lists.opensuse.org/opensuse-updates/2015-12/msg00071.html
- http://lists.opensuse.org/opensuse-updates/2015-12/msg00087.html
- http://marc.info/?l=bugtraq&m=145382583417444&w=2
- http://openssl.org/news/secadv/20151203.txt
- http://rhn.redhat.com/errata/RHSA-2015-2617.html
Get alerted when CVE-2015-3194 or the next vulnerability affects your stack