What’s Vulnerable › Vulnerabilities
CVE-2015-3214
- Severity: medium (CVSS 6.9 v2.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.6% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2015-08-31 · updated 2026-06-17
- Weakness: CWE-119
Description
The pit_ioport_read in i8254.c in the Linux kernel before 2.6.33 and QEMU before 2.3.1 does not distinguish between read lengths and write lengths, which might allow guest OS users to execute arbitrary code on the host OS by triggering use of an invalid index.
Affected products
- Arista Networks EOS: 4.12, 4.13, 4.14, 4.15
- Debian Linux: 7.0, 8.0
- Lenovo Emc Px12-400R Ivx: before 1.0.10.33264 — fixed in 1.0.10.33264
- Lenovo Emc Px12-450R Ivx: before 1.0.10.33264 — fixed in 1.0.10.33264
- Linux kernel: through 2.6.32
- QEMU: through 2.3.0
- RedHat Enterprise Linux Compute Node Eus: 7.1, 7.2, 7.3, 7.4, 7.5, 7.6 (+1)
- RedHat Enterprise Linux For Power Big Endian: 7.0
- RedHat Enterprise Linux For Power Big Endian Eus: 7.1_ppc64, 7.2_ppc64, 7.3_ppc64, 7.4_ppc64, 7.5_ppc64, 7.6_ppc64 (+1)
- RedHat Enterprise Linux For Scientific Computing: 7.0
- RedHat Enterprise Linux Server: 7.0
- RedHat Enterprise Linux Server Aus: 7.3, 7.4, 7.6, 7.7
- RedHat Enterprise Linux Server Eus: 7.1, 7.2, 7.3, 7.4, 7.5, 7.6 (+1)
- RedHat Enterprise Linux Server From Rhui: 7.0
- RedHat Enterprise Linux Server Tus: 7.3, 7.6, 7.7
- RedHat Enterprise Linux Server Update Services For Sap Solutions: 7.2, 7.3, 7.4, 7.6, 7.7
- RedHat Enterprise Linux Workstation: 7.0
- OpenStack: 5.0, 6.0
- RedHat Virtualization: 3.0
How to fix
Upgrade to a fixed version: Lenovo Emc Px12-400R Ivx 1.0.10.33264; Lenovo Emc Px12-450R Ivx 1.0.10.33264. Check the vendor advisory for mitigations.
References
- http://git.kernel.org/cgit/linux/kernel/git/torvalds/linux.git/commit/?id=ee73f656a604d5aa9df86a97102e4e462dd79924
- http://mirror.linux.org.au/linux/kernel/v2.6/ChangeLog-2.6.33
- http://rhn.redhat.com/errata/RHSA-2015-1507.html
- http://rhn.redhat.com/errata/RHSA-2015-1508.html
- http://rhn.redhat.com/errata/RHSA-2015-1512.html
- http://www.debian.org/security/2015/dsa-3348
- http://www.openwall.com/lists/oss-security/2015/06/25/7
- http://www.securityfocus.com/bid/75273
- http://www.securitytracker.com/id/1032598
- https://bugzilla.redhat.com/show_bug.cgi?id=1229640
- https://github.com/torvalds/linux/commit/ee73f656a604d5aa9df86a97102e4e462dd79924
- https://security.gentoo.org/glsa/201510-02
Get alerted when CVE-2015-3214 or the next vulnerability affects your stack