What’s Vulnerable › Vulnerabilities
CVE-2015-3276
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 5.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2015-12-07 · updated 2026-06-17
Description
The nss_parse_ciphers function in libraries/libldap/tls_m.c in OpenLDAP does not properly parse OpenSSL-style multi-keyword mode cipher strings, which might cause a weaker than intended cipher to be used and allow remote attackers to have unspecified impact via unknown vectors.
Affected products
- openldap: before 2.5 — fixed in 2.5
- Oracle Corporation Oracle Linux: 7
- RedHat Enterprise Linux Desktop: 7.0
- RedHat Enterprise Linux Eus: 7.3, 7.4, 7.5, 7.6, 7.7
- RedHat Enterprise Linux Hpc Node: 7.0
- RedHat Enterprise Linux Server: 7.0
- RedHat Enterprise Linux Server Aus: 7.3, 7.4, 7.6, 7.7
- RedHat Enterprise Linux Server Tus: 7.3, 7.6, 7.7
- RedHat Enterprise Linux Workstation: 7.0
How to fix
Upgrade to a fixed version: openldap 2.5. Check the vendor advisory for mitigations.
References
- http://rhn.redhat.com/errata/RHSA-2015-2131.html
- http://www.oracle.com/technetwork/topics/security/linuxbulletinoct2015-2719645.html
- http://www.securitytracker.com/id/1034221
- https://bugzilla.redhat.com/show_bug.cgi?id=1238322
- http://rhn.redhat.com/errata/RHSA-2015-2131.html
- http://www.oracle.com/technetwork/topics/security/linuxbulletinoct2015-2719645.html
- http://www.securitytracker.com/id/1034221
- https://bugzilla.redhat.com/show_bug.cgi?id=1238322
Get alerted when CVE-2015-3276 or the next vulnerability affects your stack