What’s Vulnerable › Vulnerabilities
CVE-2015-3331
- Severity: critical (CVSS 9.3 v2.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 10.0% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2015-05-27 · updated 2026-06-17
- Weakness: CWE-119
Description
The __driver_rfc4106_decrypt function in arch/x86/crypto/aesni-intel_glue.c in the Linux kernel before 3.19.3 does not properly determine the memory locations used for encrypted data, which allows context-dependent attackers to cause a denial of service (buffer overflow and system crash) or possibly execute arbitrary code by triggering a crypto API call, as demonstrated by use of a libkcapi test program with an AF_ALG(aead) socket.
Affected products
- Canonical Ubuntu Linux: 12.04
- Debian Linux: 7.0, 8.0
- Linux kernel: before 3.2.69; from 3.3 before 3.4.108; from 3.5 before 3.10.73; from 3.12 before 3.12.40; from 3.13 before 3.14.37; from 3.15 before 3.16.35 — fixed in 3.10.73, 3.12.40, 3.14.37, 3.16.35, 3.18.11, 3.19.3
How to fix
Upgrade to a fixed version: Linux kernel 3.10.73, 3.12.40, 3.14.37, 3.16.35. Check the vendor advisory for mitigations.
References
- http://git.kernel.org/?p=linux/kernel/git/torvalds/linux-2.6.git%3Ba=commit%3Bh=ccfe8c3f7e52ae83155cb038753f4c75b774ca8a
- http://lists.opensuse.org/opensuse-security-announce/2015-09/msg00004.html
- http://lists.opensuse.org/opensuse-security-announce/2015-09/msg00007.html
- http://lists.opensuse.org/opensuse-security-announce/2015-09/msg00008.html
- http://lists.opensuse.org/opensuse-security-announce/2015-09/msg00009.html
- http://lists.opensuse.org/opensuse-security-announce/2015-09/msg00011.html
- http://rhn.redhat.com/errata/RHSA-2015-1081.html
- http://rhn.redhat.com/errata/RHSA-2015-1199.html
- http://www.debian.org/security/2015/dsa-3237
- http://www.kernel.org/pub/linux/kernel/v3.x/ChangeLog-3.19.3
- http://www.openwall.com/lists/oss-security/2015/04/14/16
- http://www.oracle.com/technetwork/topics/security/linuxbulletinjan2016-2867209.html
Get alerted when CVE-2015-3331 or the next vulnerability affects your stack