What’s Vulnerable › Vulnerabilities
CVE-2015-3361
- Severity: low (CVSS 2.1 v2.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2015-04-21 · updated 2026-06-17
- Weakness: CWE-79
Description
Cross-site scripting (XSS) vulnerability in the Linkit module before 7.x-2.7 and 7.x-3.x before 7.x-3.3 for Drupal, when the node search plugin is enabled, allows remote authenticated users to inject arbitrary web script or HTML via a node title.
Affected products
- Linkit Project Linkit: from 7.x-1.0 before 7.x-2.7; from 7.x-3.0 before 7.x-3.3 — fixed in 7.x-2.7, 7.x-3.3
How to fix
Upgrade to a fixed version: Linkit Project Linkit 7.x-2.7, 7.x-3.3. Check the vendor advisory for mitigations.
References
- http://www.openwall.com/lists/oss-security/2015/01/29/6
- http://www.securityfocus.com/bid/71959
- https://www.drupal.org/node/2402855
- https://www.drupal.org/node/2402859
- https://www.drupal.org/node/2403459
- http://www.openwall.com/lists/oss-security/2015/01/29/6
- http://www.securityfocus.com/bid/71959
- https://www.drupal.org/node/2402855
- https://www.drupal.org/node/2402859
- https://www.drupal.org/node/2403459
Get alerted when CVE-2015-3361 or the next vulnerability affects your stack