What’s Vulnerable › Vulnerabilities
CVE-2015-3406
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2019-11-29 · updated 2026-06-17
- Weakness: CWE-681
Description
The PGP signature parsing in Module::Signature before 0.74 allows remote attackers to cause the unsigned portion of a SIGNATURE file to be treated as the signed portion via unspecified vectors.
Affected products
- Canonical Ubuntu Linux: 12.04, 14.04, 14.10, 15.04
- Module-Signature Project Module-Signature: before 0.74 — fixed in 0.74
How to fix
Upgrade to a fixed version: Module-Signature Project Module-Signature 0.74. Check the vendor advisory for mitigations.
References
- http://ubuntu.com/usn/usn-2607-1
- http://www.openwall.com/lists/oss-security/2015/04/07/1
- http://www.openwall.com/lists/oss-security/2015/04/23/17
- https://github.com/audreyt/module-signature/commit/8a9164596fa5952d4fbcde5aa1c7d1c7bc85372f
- https://metacpan.org/changes/distribution/Module-Signature
- http://ubuntu.com/usn/usn-2607-1
- http://www.openwall.com/lists/oss-security/2015/04/07/1
- http://www.openwall.com/lists/oss-security/2015/04/23/17
- https://github.com/audreyt/module-signature/commit/8a9164596fa5952d4fbcde5aa1c7d1c7bc85372f
- https://metacpan.org/changes/distribution/Module-Signature
Get alerted when CVE-2015-3406 or the next vulnerability affects your stack