What’s Vulnerable › Vulnerabilities
CVE-2015-3414
- Severity: high (CVSS 7.5 v2.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 4.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2015-04-24 · updated 2026-06-17
- Weakness: CWE-908
Description
SQLite before 3.8.9 does not properly implement the dequoting of collation-sequence names, which allows context-dependent attackers to cause a denial of service (uninitialized memory access and application crash) or possibly have unspecified other impact via a crafted COLLATE clause, as demonstrated by COLLATE"""""""" at the end of a SELECT statement.
Affected products
- macOS: 10.10.5
- Apple watchOS: 1.0.1
- Canonical Ubuntu Linux: 12.04, 14.04, 15.04
- Debian Linux: 8.0
- PHP: from 5.4.0 before 5.4.42; from 5.5.0 before 5.5.26; from 5.6.0 before 5.6.10 — fixed in 5.4.42, 5.5.26, 5.6.10
- SQLite: through 3.8.8.3
How to fix
Upgrade to a fixed version: PHP 5.4.42, 5.5.26, 5.6.10. Check the vendor advisory for mitigations.
References
- http://lists.apple.com/archives/security-announce/2015/Sep/msg00005.html
- http://lists.apple.com/archives/security-announce/2015/Sep/msg00008.html
- http://rhn.redhat.com/errata/RHSA-2015-1635.html
- http://seclists.org/fulldisclosure/2015/Apr/31
- http://www.debian.org/security/2015/dsa-3252
- http://www.mandriva.com/security/advisories?name=MDVSA-2015:217
- http://www.oracle.com/technetwork/security-advisory/cpujul2018-4258247.html
- http://www.oracle.com/technetwork/topics/security/bulletinapr2016-2952098.html
- http://www.securityfocus.com/bid/74228
- http://www.securitytracker.com/id/1033703
- http://www.ubuntu.com/usn/USN-2698-1
- https://security.gentoo.org/glsa/201507-05
Get alerted when CVE-2015-3414 or the next vulnerability affects your stack