What’s Vulnerable › Vulnerabilities
CVE-2015-3619
- Severity: medium (CVSS 5.4 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.8% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2018-02-06 · updated 2026-06-17
- Weakness: CWE-79
Description
Cross-site scripting (XSS) vulnerability in assets/js/vm2admin.js in the VirtueMart component before 3.0.8 for Joomla! allows remote attackers to inject arbitrary web script or HTML via vectors involving a "double encode combination of first_name, last_name and company."
Affected products
- virtuemart.net Virtuemart component for Joomla: before 3.0.8 — fixed in 3.0.8
How to fix
Upgrade to a fixed version: virtuemart.net Virtuemart component for Joomla 3.0.8. Check the vendor advisory for mitigations.
References
- http://dev.virtuemart.net/projects/virtuemart/repository/diff/trunk/virtuemart/administrator/components/com_virtuemart/assets/js/vm2admin.js?utf8=%E2%9C%93&rev=8828&rev_to=8670
- https://fortiguard.com/zeroday/FG-VD-15-027
- https://virtuemart.net/news/470-release-vm3-0-8-2-secured-by-fortinet-s-fortiguard-labs
- http://dev.virtuemart.net/projects/virtuemart/repository/diff/trunk/virtuemart/administrator/components/com_virtuemart/assets/js/vm2admin.js?utf8=%E2%9C%93&rev=8828&rev_to=8670
- https://fortiguard.com/zeroday/FG-VD-15-027
- https://virtuemart.net/news/470-release-vm3-0-8-2-secured-by-fortinet-s-fortiguard-labs
Get alerted when CVE-2015-3619 or the next vulnerability affects your stack