What’s Vulnerable › Vulnerabilities
CVE-2015-4002
- Severity: critical (CVSS 9.0 v2.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 8.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2015-06-07 · updated 2026-06-17
- Weakness: CWE-119
Description
drivers/staging/ozwpan/ozusbsvc1.c in the OZWPAN driver in the Linux kernel through 4.0.5 does not ensure that certain length values are sufficiently large, which allows remote attackers to cause a denial of service (system crash or large loop) or possibly execute arbitrary code via a crafted packet, related to the (1) oz_usb_rx and (2) oz_usb_handle_ep_data functions.
Affected products
- Canonical Ubuntu Linux: 14.04, 15.10
- Linux kernel: before 3.4.109; from 3.5 before 3.10.81; from 3.11 before 3.12.45; from 3.13 before 3.14.45; from 3.15 before 3.16.35; from 3.17 before 3.18.18 — fixed in 3.10.81, 3.12.45, 3.14.45, 3.16.35, 3.18.18, 3.4.109
- Opensuse: 13.2
How to fix
Upgrade to a fixed version: Linux kernel 3.10.81, 3.12.45, 3.14.45, 3.16.35. Check the vendor advisory for mitigations.
References
- http://git.kernel.org/cgit/linux/kernel/git/torvalds/linux.git/commit/?id=9a59029bc218b48eff8b5d4dde5662fd79d3e1a8
- http://git.kernel.org/cgit/linux/kernel/git/torvalds/linux.git/commit/?id=d114b9fe78c8d6fc6e70808c2092aa307c36dc8e
- http://lists.opensuse.org/opensuse-security-announce/2015-08/msg00011.html
- http://openwall.com/lists/oss-security/2015/06/05/7
- http://www.securityfocus.com/bid/74668
- http://www.ubuntu.com/usn/USN-2665-1
- http://www.ubuntu.com/usn/USN-2667-1
- https://github.com/torvalds/linux/commit/9a59029bc218b48eff8b5d4dde5662fd79d3e1a8
- https://github.com/torvalds/linux/commit/d114b9fe78c8d6fc6e70808c2092aa307c36dc8e
- http://git.kernel.org/cgit/linux/kernel/git/torvalds/linux.git/commit/?id=9a59029bc218b48eff8b5d4dde5662fd79d3e1a8
- http://git.kernel.org/cgit/linux/kernel/git/torvalds/linux.git/commit/?id=d114b9fe78c8d6fc6e70808c2092aa307c36dc8e
- http://lists.opensuse.org/opensuse-security-announce/2015-08/msg00011.html
Get alerted when CVE-2015-4002 or the next vulnerability affects your stack