What’s Vulnerable › Vulnerabilities
CVE-2015-4003
- Severity: high (CVSS 7.8 v2.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 5.8% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2015-06-07 · updated 2026-06-17
- Weakness: CWE-189
Description
The oz_usb_handle_ep_data function in drivers/staging/ozwpan/ozusbsvc1.c in the OZWPAN driver in the Linux kernel through 4.0.5 allows remote attackers to cause a denial of service (divide-by-zero error and system crash) via a crafted packet.
Affected products
- Linux kernel: from 3.4 before 3.4.109; from 3.5 before 3.10.81; from 3.11 before 3.12.45; from 3.13 before 3.14.45; from 3.15 before 3.16.35; from 3.17 before 3.18.18 — fixed in 3.10.81, 3.12.45, 3.14.45, 3.16.35, 3.18.18, 3.4.109
How to fix
Upgrade to a fixed version: Linux kernel 3.10.81, 3.12.45, 3.14.45, 3.16.35. Check the vendor advisory for mitigations.
References
- http://git.kernel.org/cgit/linux/kernel/git/torvalds/linux.git/commit/?id=04bf464a5dfd9ade0dda918e44366c2c61fce80b
- http://lists.opensuse.org/opensuse-security-announce/2015-08/msg00011.html
- http://openwall.com/lists/oss-security/2015/06/05/7
- http://www.securityfocus.com/bid/74668
- http://www.ubuntu.com/usn/USN-2665-1
- http://www.ubuntu.com/usn/USN-2667-1
- https://github.com/torvalds/linux/commit/04bf464a5dfd9ade0dda918e44366c2c61fce80b
- http://git.kernel.org/cgit/linux/kernel/git/torvalds/linux.git/commit/?id=04bf464a5dfd9ade0dda918e44366c2c61fce80b
- http://lists.opensuse.org/opensuse-security-announce/2015-08/msg00011.html
- http://openwall.com/lists/oss-security/2015/06/05/7
- http://www.securityfocus.com/bid/74668
- http://www.ubuntu.com/usn/USN-2665-1
Get alerted when CVE-2015-4003 or the next vulnerability affects your stack