What’s Vulnerable › Vulnerabilities
CVE-2015-4004
- Severity: high (CVSS 8.5 v2.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 8.1% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2015-06-07 · updated 2026-06-17
- Weakness: CWE-119
Description
The OZWPAN driver in the Linux kernel through 4.0.5 relies on an untrusted length field during packet parsing, which allows remote attackers to obtain sensitive information from kernel memory or cause a denial of service (out-of-bounds read and system crash) via a crafted packet.
Affected products
- Canonical Ubuntu Linux: 12.04, 14.04, 15.10
- Linux kernel: from 3.4 before 4.3 — fixed in 4.3
How to fix
Upgrade to a fixed version: Linux kernel 4.3. Check the vendor advisory for mitigations.
References
- http://openwall.com/lists/oss-security/2015/06/05/7
- http://www.securityfocus.com/bid/74669
- http://www.ubuntu.com/usn/USN-2989-1
- http://www.ubuntu.com/usn/USN-2998-1
- http://www.ubuntu.com/usn/USN-3000-1
- http://www.ubuntu.com/usn/USN-3001-1
- http://www.ubuntu.com/usn/USN-3002-1
- http://www.ubuntu.com/usn/USN-3003-1
- http://www.ubuntu.com/usn/USN-3004-1
- https://lkml.org/lkml/2015/5/13/739
- http://openwall.com/lists/oss-security/2015/06/05/7
- http://www.securityfocus.com/bid/74669
Get alerted when CVE-2015-4004 or the next vulnerability affects your stack