What’s Vulnerable › Vulnerabilities
CVE-2015-4010
- Severity: medium (CVSS 6.8 v2.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 4.7% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2015-06-09 · updated 2026-06-17
- Weakness: CWE-352
Description
Cross-site request forgery (CSRF) vulnerability in the Encrypted Contact Form plugin before 1.1 for WordPress allows remote attackers to hijack the authentication of administrators for requests that conduct cross-site scripting (XSS) attacks via the iframe_url parameter in an Update Page action in the conformconf page to wp-admin/options-general.php.
Affected products
- Everybit Encrypted Contact Form: before 1.1 — fixed in 1.1
How to fix
Upgrade to a fixed version: Everybit Encrypted Contact Form 1.1. Check the vendor advisory for mitigations.
References
- http://marc.info/?l=bugtraq&m=142607790919348&w=2
- http://packetstormsecurity.com/files/132209/WordPress-Encrypted-Contact-Form-1.0.4-CSRF-XSS.html
- http://seclists.org/fulldisclosure/2015/May/63
- http://www.securityfocus.com/archive/1/535699/100/0/threaded
- http://www.securityfocus.com/bid/73433
- https://plugins.trac.wordpress.org/changeset/1125443/
- https://wordpress.org/plugins/encrypted-contact-form/changelog/
- https://wpvulndb.com/vulnerabilities/7992
- https://www.exploit-db.com/exploits/37264/
- http://marc.info/?l=bugtraq&m=142607790919348&w=2
- http://packetstormsecurity.com/files/132209/WordPress-Encrypted-Contact-Form-1.0.4-CSRF-XSS.html
- http://seclists.org/fulldisclosure/2015/May/63
Get alerted when CVE-2015-4010 or the next vulnerability affects your stack