What’s Vulnerable › Vulnerabilities
CVE-2015-4036
- Severity: high (CVSS 7.2 v2.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2015-08-31 · updated 2026-06-17
- Weakness: CWE-119
Description
Array index error in the tcm_vhost_make_tpg function in drivers/vhost/scsi.c in the Linux kernel before 4.0 might allow guest OS users to cause a denial of service (memory corruption) or possibly have unspecified other impact via a crafted VHOST_SCSI_SET_ENDPOINT ioctl call. NOTE: the affected function was renamed to vhost_scsi_make_tpg before the vulnerability was announced.
Affected products
- Linux kernel: from 3.6 (excl.) before 3.10.90; from 3.11 before 3.12.44; from 3.13 before 3.14.57; from 3.15 before 3.16.35; from 3.17 before 3.18.25; from 3.19 before 4.0 — fixed in 3.10.90, 3.12.44, 3.14.57, 3.16.35, 3.18.25, 4.0
How to fix
Upgrade to a fixed version: Linux kernel 3.10.90, 3.12.44, 3.14.57, 3.16.35. Check the vendor advisory for mitigations.
References
- http://git.kernel.org/cgit/linux/kernel/git/torvalds/linux.git/commit/?id=59c816c1f24df0204e01851431d3bab3eb76719c
- http://lists.opensuse.org/opensuse-security-announce/2015-07/msg00049.html
- http://lists.opensuse.org/opensuse-security-announce/2015-08/msg00011.html
- http://www.openwall.com/lists/oss-security/2015/05/13/4
- http://www.securityfocus.com/bid/74664
- http://www.securitytracker.com/id/1033729
- http://www.ubuntu.com/usn/USN-2633-1
- http://www.ubuntu.com/usn/USN-2634-1
- https://bugzilla.redhat.com/show_bug.cgi?id=1189864
- https://github.com/torvalds/linux/commit/59c816c1f24df0204e01851431d3bab3eb76719c
- http://git.kernel.org/cgit/linux/kernel/git/torvalds/linux.git/commit/?id=59c816c1f24df0204e01851431d3bab3eb76719c
- http://lists.opensuse.org/opensuse-security-announce/2015-07/msg00049.html
Get alerted when CVE-2015-4036 or the next vulnerability affects your stack