What’s Vulnerable › Vulnerabilities
CVE-2015-4117
- Severity: high (CVSS 8.8 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 10.6% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2018-02-28 · updated 2026-06-17
- Weakness: CWE-78
Description
Vesta Control Panel before 0.9.8-14 allows remote authenticated users to execute arbitrary commands via shell metacharacters in the backup parameter to list/backup/index.php.
Affected products
- Vesta Control Panel: before 0.9.8-14 — fixed in 0.9.8-14
How to fix
Upgrade to a fixed version: Vesta Control Panel 0.9.8-14. Check the vendor advisory for mitigations.
References
- http://vestacp.com/roadmap/#history
- https://www.exploit-db.com/exploits/37369/
- https://www.htbridge.com/advisory/HTB23261
- http://vestacp.com/roadmap/#history
- https://www.exploit-db.com/exploits/37369/
- https://www.htbridge.com/advisory/HTB23261
Get alerted when CVE-2015-4117 or the next vulnerability affects your stack