What’s Vulnerable › Vulnerabilities
CVE-2015-4557
- Severity: medium (CVSS 6.1 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.9% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2018-04-12 · updated 2026-06-17
- Weakness: CWE-79
Description
Cross-site scripting (XSS) vulnerability in the new_Twitter_sign_button function in nextend-Twitter-connect.php in the Nextend Twitter Connect plugin before 1.5.2 for WordPress allows remote attackers to inject arbitrary web script or HTML via the redirect_to parameter. NOTE: this may overlap CVE-2015-4413.
Affected products
- nextendweb Nextend Twitter Connect: before 1.5.2 — fixed in 1.5.2
How to fix
Upgrade to a fixed version: nextendweb Nextend Twitter Connect 1.5.2. Check the vendor advisory for mitigations.
References
- http://packetstormsecurity.com/files/132432/WordPress-Nextend-Twitter-Connect-1.5.1-Cross-Site-Scripting.html
- http://seclists.org/fulldisclosure/2015/Jun/71
- http://www.securityfocus.com/bid/75395
- https://plugins.trac.wordpress.org/changeset/1178744/nextend-twitter-connect
- http://packetstormsecurity.com/files/132432/WordPress-Nextend-Twitter-Connect-1.5.1-Cross-Site-Scripting.html
- http://seclists.org/fulldisclosure/2015/Jun/71
- http://www.securityfocus.com/bid/75395
- https://plugins.trac.wordpress.org/changeset/1178744/nextend-twitter-connect
Get alerted when CVE-2015-4557 or the next vulnerability affects your stack