What’s Vulnerable › Vulnerabilities

CVE-2015-4630

Description

Multiple cross-site request forgery (CSRF) vulnerabilities in Koha 3.14.x before 3.14.16, 3.16.x before 3.16.12, 3.18.x before 3.18.08, and 3.20.x before 3.20.1 allow remote attackers to (1) hijack the authentication of administrators for requests that create a user via a request to members/memberentry.pl or (2) give a user superlibrarian permission via a request to members/member-flags.pl or (3) hijack the authentication of arbitrary users for requests that conduct cross-site scripting (XSS) attacks via the addshelf parameter to opac-shelves.pl.

Affected products

How to fix

Upgrade to a fixed version: Koha Community Koha 3.14.16, 3.16.12, 3.18.8, 3.20.1. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2015-4630 or the next vulnerability affects your stack