What’s Vulnerable › Vulnerabilities

CVE-2015-4632

Description

Multiple directory traversal vulnerabilities in Koha 3.14.x before 3.14.16, 3.16.x before 3.16.12, 3.18.x before 3.18.08, and 3.20.x before 3.20.1 allow remote attackers to read arbitrary files via a ..%2f (dot dot encoded slash) in the template_path parameter to (1) svc/virtualshelves/search or (2) svc/members/search.

Affected products

How to fix

Upgrade to a fixed version: Koha Community Koha 3.14.16, 3.16.12, 3.18.08, 3.20.01. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2015-4632 or the next vulnerability affects your stack