What’s Vulnerable › Vulnerabilities

CVE-2015-4643

Description

Integer overflow in the ftp_genlist function in ext/ftp/ftp.c in PHP before 5.4.42, 5.5.x before 5.5.26, and 5.6.x before 5.6.10 allows remote FTP servers to execute arbitrary code via a long reply to a LIST command, leading to a heap-based buffer overflow. NOTE: this vulnerability exists because of an incomplete fix for CVE-2015-4022.

Affected products

How to fix

Upgrade to a fixed version: PHP 5.4.42, 5.5.26, 5.6.10. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2015-4643 or the next vulnerability affects your stack