What’s Vulnerable › Vulnerabilities
CVE-2015-4707
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2017-09-20 · updated 2026-06-17
- Weakness: CWE-79
Description
Cross-site scripting (XSS) vulnerability in IPython before 3.2 allows remote attackers to inject arbitrary web script or HTML via vectors involving JSON error messages and the /api/notebooks path.
Affected products
- ipython: before 3.2.0 — fixed in 3.2.0
How to fix
Upgrade to a fixed version: ipython 3.2.0. Check the vendor advisory for mitigations.
References
- http://www.openwall.com/lists/oss-security/2015/06/22/7
- http://www.securityfocus.com/bid/75328
- https://bugzilla.redhat.com/show_bug.cgi?id=1235688
- https://github.com/ipython/ipython/commit/7222bd53ad089a65fd610fab4626f9d0ab47dfce
- https://github.com/ipython/ipython/commit/c2078a53543ed502efd968649fee1125e0eb549c
- https://ipython.org/ipython-doc/3/whatsnew/version3.html
- http://www.openwall.com/lists/oss-security/2015/06/22/7
- http://www.securityfocus.com/bid/75328
- https://bugzilla.redhat.com/show_bug.cgi?id=1235688
- https://github.com/ipython/ipython/commit/7222bd53ad089a65fd610fab4626f9d0ab47dfce
- https://github.com/ipython/ipython/commit/c2078a53543ed502efd968649fee1125e0eb549c
- https://ipython.org/ipython-doc/3/whatsnew/version3.html
Get alerted when CVE-2015-4707 or the next vulnerability affects your stack