What’s Vulnerable › Vulnerabilities
CVE-2015-4757
- Severity: low (CVSS 3.5 v2.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 7.0% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2015-07-16 · updated 2026-06-17
Description
Unspecified vulnerability in Oracle MySQL Server 5.5.42 and earlier and 5.6.23 and earlier allows remote authenticated users to affect availability via unknown vectors related to Server : Optimizer.
Affected products
- Canonical Ubuntu Linux: 12.04, 14.04, 14.10, 15.04
- Debian Linux: 8.0
- MariaDB: from 5.5.0 before 5.5.43; from 10.0.0 before 10.0.18 — fixed in 10.0.18, 5.5.43
- Opensuse: 13.1, 13.2
- MySQL Server: from 5.5.0 through 5.5.42; from 5.6.0 through 5.6.23
- RedHat Enterprise Linux Desktop: 5.0, 7.0
- RedHat Enterprise Linux Eus: 7.1, 7.2, 7.3, 7.4, 7.5, 7.6 (+1)
- RedHat Enterprise Linux Server: 5.0, 7.0
- RedHat Enterprise Linux Server Aus: 7.3, 7.4, 7.6, 7.7
- RedHat Enterprise Linux Server Tus: 7.3, 7.6, 7.7
- RedHat Enterprise Linux Workstation: 5.0, 7.0
How to fix
Upgrade to a fixed version: MariaDB 10.0.18, 5.5.43. Check the vendor advisory for mitigations.
References
- http://lists.opensuse.org/opensuse-updates/2015-09/msg00042.html
- http://rhn.redhat.com/errata/RHSA-2015-1628.html
- http://rhn.redhat.com/errata/RHSA-2015-1629.html
- http://rhn.redhat.com/errata/RHSA-2015-1630.html
- http://rhn.redhat.com/errata/RHSA-2015-1646.html
- http://rhn.redhat.com/errata/RHSA-2015-1647.html
- http://rhn.redhat.com/errata/RHSA-2015-1665.html
- http://www.debian.org/security/2015/dsa-3311
- http://www.oracle.com/technetwork/topics/security/cpujul2015-2367936.html
- http://www.securityfocus.com/bid/75759
- http://www.securitytracker.com/id/1032911
- http://www.ubuntu.com/usn/USN-2674-1
Get alerted when CVE-2015-4757 or the next vulnerability affects your stack