What’s Vulnerable › Vulnerabilities
CVE-2015-4879
- Severity: medium (CVSS 4.6 v2.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 4.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2015-10-21 · updated 2026-06-17
Description
Unspecified vulnerability in Oracle MySQL Server 5.5.44 and earlier, and 5.6.25 and earlier, allows remote authenticated users to affect confidentiality, integrity, and availability via vectors related to DML.
Affected products
- Canonical Ubuntu Linux: 12.04, 14.04, 15.04, 15.10
- Debian Linux: 7.0, 8.0
- Fedoraproject Fedora: 23
- MariaDB: from 5.5.0 before 5.5.45; from 10.0.0 before 10.0.21; from 10.1.0 before 10.1.8 — fixed in 10.0.21, 10.1.8, 5.5.45
- Oracle Corporation Oracle Linux: 7
- MySQL Server: from 5.5.0 through 5.5.44; from 5.6.0 through 5.6.25
- Oracle Corporation Solaris Operating System: 11.3
- RedHat Enterprise Linux Desktop: 7.0
- RedHat Enterprise Linux Eus: 7.2, 7.3, 7.4, 7.5, 7.6, 7.7
- RedHat Enterprise Linux Server: 7.0
- RedHat Enterprise Linux Server Aus: 7.2, 7.3, 7.4, 7.6, 7.7
- RedHat Enterprise Linux Server Tus: 7.2, 7.3, 7.6, 7.7
- RedHat Enterprise Linux Workstation: 7.0
How to fix
Upgrade to a fixed version: MariaDB 10.0.21, 10.1.8, 5.5.45. Check the vendor advisory for mitigations.
References
- http://lists.fedoraproject.org/pipermail/package-announce/2016-February/177539.html
- http://rhn.redhat.com/errata/RHSA-2015-1628.html
- http://rhn.redhat.com/errata/RHSA-2016-0534.html
- http://rhn.redhat.com/errata/RHSA-2016-1481.html
- http://www.debian.org/security/2015/dsa-3377
- http://www.debian.org/security/2015/dsa-3385
- http://www.oracle.com/technetwork/topics/security/bulletinapr2016-2952098.html
- http://www.oracle.com/technetwork/topics/security/cpuoct2015-2367953.html
- http://www.oracle.com/technetwork/topics/security/linuxbulletinapr2016-2952096.html
- http://www.securityfocus.com/bid/77140
- http://www.securitytracker.com/id/1033894
- http://www.ubuntu.com/usn/USN-2781-1
Get alerted when CVE-2015-4879 or the next vulnerability affects your stack