What’s Vulnerable › Vulnerabilities
CVE-2015-5041
- Severity: critical (CVSS 9.1 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 3.9% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2016-06-06 · updated 2026-06-17
- Weakness: CWE-200
Description
The J9 JVM in IBM SDK, Java Technology Edition 6 before SR16 FP20, 6 R1 before SR8 FP20, 7 before SR9 FP30, and 7 R1 before SR3 FP30 allows remote attackers to obtain sensitive information or inject data by invoking non-public interface methods.
Affected products
- IBM SDK, Java Technology Edition: from 6.0.0.0 before 6.0.16.20; from 6.1.0.0 before 6.1.8.20; from 7.0.0.0 before 7.0.9.30; from 7.1.0.0 before 7.1.3.30 — fixed in 6.0.16.20, 6.1.8.20, 7.0.9.30, 7.1.3.30
- IBM WebSphere Application Server: through 3.0.9.20
- Red Hat Satellite 6: 5.6, 5.7
- SUSE Linux Enterprise Server: 11-sp2, 11-sp4, 12-sp1
- SUSE Linux Enterprise Software Development Kit: 11-sp4, 12, 12-sp1
- SUSE Linux Enterprise: 12
How to fix
Upgrade to a fixed version: IBM SDK, Java Technology Edition 6.0.16.20, 6.1.8.20, 7.0.9.30, 7.1.3.30. Check the vendor advisory for mitigations.
References
- http://lists.opensuse.org/opensuse-security-announce/2016-02/msg00026.html
- http://lists.opensuse.org/opensuse-security-announce/2016-02/msg00028.html
- http://lists.opensuse.org/opensuse-security-announce/2016-02/msg00031.html
- http://lists.opensuse.org/opensuse-security-announce/2016-02/msg00032.html
- http://www-01.ibm.com/support/docview.wss?uid=swg1IV72872
- http://www-01.ibm.com/support/docview.wss?uid=swg21974194
- http://www.securityfocus.com/bid/82451
- https://access.redhat.com/errata/RHSA-2016:1430
- http://lists.opensuse.org/opensuse-security-announce/2016-02/msg00026.html
- http://lists.opensuse.org/opensuse-security-announce/2016-02/msg00028.html
- http://lists.opensuse.org/opensuse-security-announce/2016-02/msg00031.html
- http://lists.opensuse.org/opensuse-security-announce/2016-02/msg00032.html
Get alerted when CVE-2015-5041 or the next vulnerability affects your stack