What’s Vulnerable › Vulnerabilities
CVE-2015-5065
- Severity: medium (CVSS 5.0 v2.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 16.2% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2015-06-24 · updated 2026-06-17
- Weakness: CWE-22
Description
Absolute path traversal vulnerability in proxy.php in the google currency lookup in the Paypal Currency Converter Basic For WooCommerce plugin before 1.4 for WordPress allows remote attackers to read arbitrary files via a full pathname in the requrl parameter.
Affected products
- Intelligent-It Paypal Currency Converter Basic For Woocommerce: before 1.4 — fixed in 1.4
How to fix
Upgrade to a fixed version: Intelligent-It Paypal Currency Converter Basic For Woocommerce 1.4. Check the vendor advisory for mitigations.
References
- http://packetstormsecurity.com/files/132278/WordPress-Paypal-Currency-Converter-Basic-For-Woocommerce-1.3-File-Read.html
- http://www.securityfocus.com/bid/75416
- https://plugins.trac.wordpress.org/changeset/1179092/paypal-currency-converter-basic-for-woocommerce
- https://wordpress.org/plugins/paypal-currency-converter-basic-for-woocommerce/changelog/
- https://www.exploit-db.com/exploits/37253/
- http://packetstormsecurity.com/files/132278/WordPress-Paypal-Currency-Converter-Basic-For-Woocommerce-1.3-File-Read.html
- http://www.securityfocus.com/bid/75416
- https://plugins.trac.wordpress.org/changeset/1179092/paypal-currency-converter-basic-for-woocommerce
- https://wordpress.org/plugins/paypal-currency-converter-basic-for-woocommerce/changelog/
- https://www.exploit-db.com/exploits/37253/
Get alerted when CVE-2015-5065 or the next vulnerability affects your stack