What’s Vulnerable › Vulnerabilities
CVE-2015-5157
- Severity: high (CVSS 7.2 v2.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2015-08-31 · updated 2026-06-17
- Weakness: CWE-264
Description
arch/x86/entry/entry_64.S in the Linux kernel before 4.1.6 on the x86_64 platform mishandles IRET faults in processing NMIs that occurred during userspace execution, which might allow local users to gain privileges by triggering an NMI.
Affected products
- Linux kernel: before 3.12.47; from 3.13 before 3.14.54; from 3.15 before 3.16.35; from 3.17 before 3.18.22; from 3.19 before 4.1.6 — fixed in 3.12.47, 3.14.54, 3.16.35, 3.18.22, 4.1.6
- RedHat Enterprise Linux Desktop: 6.0
- RedHat Enterprise Linux Hpc Node: 6.0
- RedHat Enterprise Linux Server: 6.0
- RedHat Enterprise Linux Server Eus: 6.7.z
- RedHat Enterprise Linux Workstation: 6.0
How to fix
Upgrade to a fixed version: Linux kernel 3.12.47, 3.14.54, 3.16.35, 3.18.22. Check the vendor advisory for mitigations.
References
- http://git.kernel.org/cgit/linux/kernel/git/torvalds/linux.git/commit/?id=9b6e6a8334d56354853f9c255d1395c2ba570e0a
- http://lists.opensuse.org/opensuse-security-announce/2015-10/msg00009.html
- http://lists.opensuse.org/opensuse-security-announce/2015-11/msg00035.html
- http://lists.opensuse.org/opensuse-security-announce/2015-12/msg00026.html
- http://lists.opensuse.org/opensuse-security-announce/2015-12/msg00031.html
- http://lists.opensuse.org/opensuse-security-announce/2016-02/msg00013.html
- http://rhn.redhat.com/errata/RHSA-2016-0185.html
- http://rhn.redhat.com/errata/RHSA-2016-0212.html
- http://rhn.redhat.com/errata/RHSA-2016-0224.html
- http://rhn.redhat.com/errata/RHSA-2016-0715.html
- http://www.debian.org/security/2015/dsa-3313
- http://www.kernel.org/pub/linux/kernel/v4.x/ChangeLog-4.1.6
Get alerted when CVE-2015-5157 or the next vulnerability affects your stack