What’s Vulnerable › Vulnerabilities
CVE-2015-5158
- Severity: medium (CVSS 5.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2016-04-12 · updated 2026-06-17
- Weakness: CWE-787
Description
Stack-based buffer overflow in hw/scsi/scsi-bus.c in QEMU, when built with SCSI-device emulation support, allows guest OS users with CAP_SYS_RAWIO permissions to cause a denial of service (instance crash) via an invalid opcode in a SCSI command descriptor block.
Affected products
- QEMU: from 2.2.0 before 2.4.0; 2.4.0, 2.4.0-rc1, 2.4.0-rc2 — fixed in 2.4.0
How to fix
Upgrade to a fixed version: QEMU 2.4.0. Check the vendor advisory for mitigations.
References
- http://www.securityfocus.com/bid/76016
- http://www.securitytracker.com/id/1033095
- https://lists.nongnu.org/archive/html/qemu-devel/2015-07/msg04558.html
- https://security.gentoo.org/glsa/201510-02
- http://www.securityfocus.com/bid/76016
- http://www.securitytracker.com/id/1033095
- https://lists.nongnu.org/archive/html/qemu-devel/2015-07/msg04558.html
- https://security.gentoo.org/glsa/201510-02
Get alerted when CVE-2015-5158 or the next vulnerability affects your stack