What’s Vulnerable › Vulnerabilities
CVE-2015-5215
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2020-02-17 · updated 2026-06-17
- Weakness: CWE-79
Description
The default configuration of the Jinja templating engine used in the Identity Provider (IdP) server in Ipsilon 0.1.0 before 1.0.1 does not enable auto-escaping, which makes it easier for remote attackers to conduct cross-site scripting (XSS) attacks via template variables. NOTE: This may be a duplicate of CVE-2015-5216. Moreover, the Jinja development team does not enable auto-escape by default for performance issues as explained in https://jinja.palletsprojects.com/en/master/faq/#why-is-autoescaping-not-the-default.
Affected products
- Ipsilon: from 0.1.0 before 1.0.1 — fixed in 1.0.1
How to fix
Upgrade to a fixed version: Ipsilon 1.0.1. Check the vendor advisory for mitigations.
References
- http://www.openwall.com/lists/oss-security/2015/10/23/10
- https://bugzilla.redhat.com/show_bug.cgi?id=1255168
- https://fedorahosted.org/ipsilon/wiki/Releases/v1.0.1
- https://pagure.io/ipsilon/a503aa9c2a30a74e709d1c88099befd50fb2eb16
- http://www.openwall.com/lists/oss-security/2015/10/23/10
- https://bugzilla.redhat.com/show_bug.cgi?id=1255168
- https://fedorahosted.org/ipsilon/wiki/Releases/v1.0.1
- https://pagure.io/ipsilon/a503aa9c2a30a74e709d1c88099befd50fb2eb16
Get alerted when CVE-2015-5215 or the next vulnerability affects your stack