What’s Vulnerable › Vulnerabilities
CVE-2015-5216
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2020-02-17 · updated 2026-06-17
- Weakness: CWE-79
Description
The Identity Provider (IdP) server in Ipsilon 0.1.0 before 1.0.1 does not properly escape certain characters in a Python exception-message template, which makes it easier for remote attackers to conduct cross-site scripting (XSS) attacks via an HTTP response.
Affected products
- Ipsilon: from 0.1.0 before 1.0.1 — fixed in 1.0.1
How to fix
Upgrade to a fixed version: Ipsilon 1.0.1. Check the vendor advisory for mitigations.
References
- http://www.openwall.com/lists/oss-security/2015/10/27/8
- https://bugzilla.redhat.com/show_bug.cgi?id=1255170
- https://pagure.io/ipsilon/a503aa9c2a30a74e709d1c88099befd50fb2eb16
- http://www.openwall.com/lists/oss-security/2015/10/27/8
- https://bugzilla.redhat.com/show_bug.cgi?id=1255170
- https://pagure.io/ipsilon/a503aa9c2a30a74e709d1c88099befd50fb2eb16
Get alerted when CVE-2015-5216 or the next vulnerability affects your stack