What’s Vulnerable › Vulnerabilities
CVE-2015-5230
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 9.0% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2020-01-15 · updated 2026-06-17
- Weakness: CWE-20
Description
The DNS packet parsing/generation code in PowerDNS (aka pdns) Authoritative Server 3.4.x before 3.4.6 allows remote attackers to cause a denial of service (crash) via crafted query packets.
Affected products
- Debian Linux: 8.0, 9.0
- PowerDNS Authoritative: from 3.4.0 before 3.4.6 — fixed in 3.4.6
How to fix
Upgrade to a fixed version: PowerDNS Authoritative 3.4.6. Check the vendor advisory for mitigations.
References
- http://www.debian.org/security/2015/dsa-3347
- http://www.securitytracker.com/id/1033475
- https://doc.powerdns.com/md/security/powerdns-advisory-2015-02/
- http://www.debian.org/security/2015/dsa-3347
- http://www.securitytracker.com/id/1033475
- https://doc.powerdns.com/md/security/powerdns-advisory-2015-02/
Get alerted when CVE-2015-5230 or the next vulnerability affects your stack