What’s Vulnerable › Vulnerabilities
CVE-2015-5239
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 3.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2020-01-23 · updated 2026-06-17
- Weakness: CWE-835
Description
Integer overflow in the VNC display driver in QEMU before 2.1.0 allows attachers to cause a denial of service (process crash) via a CLIENT_CUT_TEXT message, which triggers an infinite loop.
Affected products
- Arista Networks EOS: 4.12, 4.13, 4.14, 4.15
- Canonical Ubuntu Linux: 12.04, 14.04, 15.04
- Fedoraproject Fedora: 21, 22, 23
- QEMU: before 2.1.0 — fixed in 2.1.0
- SUSE Linux Enterprise Debuginfo: 11-sp3, 11-sp4
- SUSE Linux Enterprise Server 15 SP1: 11-sp3, 11-sp4, 12
- SUSE Linux Enterprise Server: 11-sp3, 11-sp4, 12
- SUSE Linux Enterprise Software Development Kit: 11-sp3, 11-sp4, 12
How to fix
Upgrade to a fixed version: QEMU 2.1.0. Check the vendor advisory for mitigations.
References
- http://lists.fedoraproject.org/pipermail/package-announce/2015-October/168077.html
- http://lists.fedoraproject.org/pipermail/package-announce/2015-October/168646.html
- http://lists.fedoraproject.org/pipermail/package-announce/2015-October/168671.html
- http://lists.opensuse.org/opensuse-security-announce/2015-10/msg00026.html
- http://lists.opensuse.org/opensuse-security-announce/2015-11/msg00005.html
- http://lists.opensuse.org/opensuse-security-announce/2015-11/msg00011.html
- http://www.openwall.com/lists/oss-security/2015/09/02/7
- http://www.ubuntu.com/usn/USN-2745-1
- https://github.com/qemu/qemu/commit/f9a70e79391f6d7c2a912d785239ee8effc1922d
- https://www.arista.com/en/support/advisories-notices/security-advisories/1188-security-advisory-14
- http://lists.fedoraproject.org/pipermail/package-announce/2015-October/168077.html
- http://lists.fedoraproject.org/pipermail/package-announce/2015-October/168646.html
Get alerted when CVE-2015-5239 or the next vulnerability affects your stack