What’s Vulnerable › Vulnerabilities
CVE-2015-5289
- Severity: medium (CVSS 6.4 v2.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 5.0% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2015-10-26 · updated 2026-06-17
- Weakness: CWE-119
Description
Multiple stack-based buffer overflows in json parsing in PostgreSQL before 9.3.x before 9.3.10 and 9.4.x before 9.4.5 allow attackers to cause a denial of service (server crash) via unspecified vectors, which are not properly handled in (1) json or (2) jsonb values.
Affected products
- Canonical Ubuntu Linux: 12.04, 14.04, 15.04
- Debian Linux: 8.0, 9.0
- PostgreSQL: from 9.3.0 before 9.3.10; from 9.4.0 before 9.4.5 — fixed in 9.3.10, 9.4.5
How to fix
Upgrade to a fixed version: PostgreSQL 9.3.10, 9.4.5. Check the vendor advisory for mitigations.
References
- http://git.postgresql.org/gitweb/?p=postgresql.git%3Ba=commit%3Bh=08fa47c4850cea32c3116665975bca219fbf2fe6
- http://lists.fedoraproject.org/pipermail/package-announce/2015-November/172316.html
- http://lists.fedoraproject.org/pipermail/package-announce/2015-October/169094.html
- http://lists.opensuse.org/opensuse-security-announce/2016-03/msg00016.html
- http://lists.opensuse.org/opensuse-updates/2015-11/msg00033.html
- http://www.debian.org/security/2015/dsa-3374
- http://www.oracle.com/technetwork/topics/security/linuxbulletinoct2015-2719645.html
- http://www.postgresql.org/about/news/1615/
- http://www.postgresql.org/docs/9.3/static/release-9-3-10.html
- http://www.postgresql.org/docs/9.4/static/release-9-4-5.html
- http://www.securityfocus.com/bid/77048
- http://www.securitytracker.com/id/1033775
Get alerted when CVE-2015-5289 or the next vulnerability affects your stack