What’s Vulnerable › Vulnerabilities
CVE-2015-5297
- Severity: critical (CVSS 9.8 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2019-07-31 · updated 2026-06-17
- Weakness: CWE-190
Description
An integer overflow issue has been reported in the general_composite_rect() function in pixman prior to version 0.32.8. An attacker could exploit this issue to cause an application using pixman to crash or, potentially, execute arbitrary code.
Affected products
- The pixman Project pixman: before 0.32.8 — fixed in 0.32.8
How to fix
Upgrade to a fixed version: The pixman Project pixman 0.32.8. Check the vendor advisory for mitigations.
References
- https://bugs.freedesktop.org/show_bug.cgi?id=92027
- https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2015-5297
- https://bugs.freedesktop.org/show_bug.cgi?id=92027
- https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2015-5297
Get alerted when CVE-2015-5297 or the next vulnerability affects your stack