What’s Vulnerable › Vulnerabilities
CVE-2015-5299
- Severity: medium (CVSS 5.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 13.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2015-12-29 · updated 2026-06-17
- Weakness: CWE-200
Description
The shadow_copy2_get_shadow_copy_data function in modules/vfs_shadow_copy2.c in Samba 3.x and 4.x before 4.1.22, 4.2.x before 4.2.7, and 4.3.x before 4.3.3 does not verify that the DIRECTORY_LIST access right has been granted, which allows remote attackers to access snapshots by visiting a shadow copy directory.
Affected products
- Canonical Ubuntu Linux: 12.04, 14.04, 15.04, 15.10
- Debian Linux: 7.0, 8.0
- Samba: from 3.0.20 before 4.1.22; from 4.2.0 before 4.2.7; from 4.3.0 before 4.3.3 — fixed in 4.1.22, 4.2.7, 4.3.3
How to fix
Upgrade to a fixed version: Samba 4.1.22, 4.2.7, 4.3.3. Check the vendor advisory for mitigations.
References
- http://lists.fedoraproject.org/pipermail/package-announce/2015-December/174076.html
- http://lists.fedoraproject.org/pipermail/package-announce/2015-December/174391.html
- http://lists.opensuse.org/opensuse-security-announce/2015-12/msg00019.html
- http://lists.opensuse.org/opensuse-security-announce/2015-12/msg00020.html
- http://lists.opensuse.org/opensuse-security-announce/2015-12/msg00032.html
- http://lists.opensuse.org/opensuse-security-announce/2015-12/msg00033.html
- http://lists.opensuse.org/opensuse-security-announce/2016-01/msg00002.html
- http://lists.opensuse.org/opensuse-security-announce/2016-01/msg00017.html
- http://lists.opensuse.org/opensuse-security-announce/2016-04/msg00042.html
- http://lists.opensuse.org/opensuse-security-announce/2016-04/msg00047.html
- http://lists.opensuse.org/opensuse-security-announce/2016-04/msg00048.html
- http://www.debian.org/security/2016/dsa-3433
Get alerted when CVE-2015-5299 or the next vulnerability affects your stack