What’s Vulnerable › Vulnerabilities
CVE-2015-5316
- Severity: medium (CVSS 5.9 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 3.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2018-02-21 · updated 2026-06-17
- Weakness: CWE-476
Description
The eap_pwd_perform_confirm_exchange function in eap_peer/eap_pwd.c in wpa_supplicant 2.x before 2.6, when EAP-pwd is enabled in a network configuration profile, allows remote attackers to cause a denial of service (NULL pointer dereference and daemon crash) via an EAP-pwd Confirm message followed by the Identity exchange.
Affected products
- Debian Linux: 8.0
- Canonical Ltd. wpa_supplicant: from 2.0 before 2.6 — fixed in 2.6
How to fix
Upgrade to a fixed version: Canonical Ltd. wpa_supplicant 2.6. Check the vendor advisory for mitigations.
References
- http://w1.fi/security/2015-8/eap-pwd-unexpected-confirm.txt
- http://www.openwall.com/lists/oss-security/2015/11/10/11
- http://www.securityfocus.com/bid/77538
- http://www.ubuntu.com/usn/USN-2808-1
- https://www.debian.org/security/2015/dsa-3397
- http://w1.fi/security/2015-8/eap-pwd-unexpected-confirm.txt
- http://www.openwall.com/lists/oss-security/2015/11/10/11
- http://www.securityfocus.com/bid/77538
- http://www.ubuntu.com/usn/USN-2808-1
- https://www.debian.org/security/2015/dsa-3397
Get alerted when CVE-2015-5316 or the next vulnerability affects your stack