What’s Vulnerable › Vulnerabilities
CVE-2015-5334
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 3.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2020-01-23 · updated 2026-06-17
- Weakness: CWE-787
Description
Off-by-one error in the OBJ_obj2txt function in LibreSSL before 2.3.1 allows remote attackers to cause a denial of service (program crash) or possible execute arbitrary code via a crafted X.509 certificate, which triggers a stack-based buffer overflow. Note: this vulnerability exists because of an incorrect fix for CVE-2014-3508.
Affected products
- OpenBSD Libressl: before 2.3.1 — fixed in 2.3.1
- Opensuse: 13.2
How to fix
Upgrade to a fixed version: OpenBSD Libressl 2.3.1. Check the vendor advisory for mitigations.
References
- http://ftp.openbsd.org/pub/OpenBSD/LibreSSL/libressl-2.3.1-relnotes.txt
- http://lists.opensuse.org/opensuse-updates/2015-10/msg00050.html
- http://packetstormsecurity.com/files/133998/Qualys-Security-Advisory-LibreSSL-Leak-Overflow.html
- http://seclists.org/fulldisclosure/2015/Oct/75
- http://www.securityfocus.com/archive/1/archive/1/536692/100/0/threaded
- http://ftp.openbsd.org/pub/OpenBSD/LibreSSL/libressl-2.3.1-relnotes.txt
- http://lists.opensuse.org/opensuse-updates/2015-10/msg00050.html
- http://packetstormsecurity.com/files/133998/Qualys-Security-Advisory-LibreSSL-Leak-Overflow.html
- http://seclists.org/fulldisclosure/2015/Oct/75
- http://www.securityfocus.com/archive/1/archive/1/536692/100/0/threaded
Get alerted when CVE-2015-5334 or the next vulnerability affects your stack