What’s Vulnerable › Vulnerabilities
CVE-2015-5343
- Severity: high (CVSS 7.6 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 30.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2016-04-14 · updated 2026-06-17
- Weakness: CWE-119
Description
Integer overflow in util.c in mod_dav_svn in Apache Subversion 1.7.x, 1.8.x before 1.8.15, and 1.9.x before 1.9.3 allows remote authenticated users to cause a denial of service (subversion server crash or memory consumption) and possibly execute arbitrary code via a skel-encoded request body, which triggers an out-of-bounds read and heap-based buffer overflow.
Affected products
- Apache Software Foundation Apache Subversion: from 1.7.0 through 1.7.20; from 1.8.0 before 1.8.15; from 1.9.0 before 1.9.3 — fixed in 1.8.15, 1.9.3
- Debian Linux: 8.0
How to fix
Upgrade to a fixed version: Apache Software Foundation Apache Subversion 1.8.15, 1.9.3. Check the vendor advisory for mitigations.
References
- http://subversion.apache.org/security/CVE-2015-5343-advisory.txt
- http://www.debian.org/security/2015/dsa-3424
- http://www.securitytracker.com/id/1034470
- http://www.slackware.com/security/viewer.php?l=slackware-security&y=2016&m=slackware-security.405261
- http://subversion.apache.org/security/CVE-2015-5343-advisory.txt
- http://www.debian.org/security/2015/dsa-3424
- http://www.securitytracker.com/id/1034470
- http://www.slackware.com/security/viewer.php?l=slackware-security&y=2016&m=slackware-security.405261
Get alerted when CVE-2015-5343 or the next vulnerability affects your stack