What’s Vulnerable › Vulnerabilities
CVE-2015-5347
- Severity: medium (CVSS 6.1 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 8.2% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2016-04-12 · updated 2026-06-17
- Weakness: CWE-79
Description
Cross-site scripting (XSS) vulnerability in the getWindowOpenJavaScript function in org.apache.wicket.extensions.ajax.markup.html.modal.ModalWindow in Apache Wicket 1.5.x before 1.5.15, 6.x before 6.22.0, and 7.x before 7.2.0 might allow remote attackers to inject arbitrary web script or HTML via a ModalWindow title.
Affected products
- Apache Software Foundation Apache Wicket: from 1.5.0 before 1.5.15; from 6.0.0 before 6.22.0; from 7.0 before 7.2.0 — fixed in 1.5.15, 6.22.0, 7.2.0
How to fix
Upgrade to a fixed version: Apache Software Foundation Apache Wicket 1.5.15, 6.22.0, 7.2.0. Check the vendor advisory for mitigations.
References
- http://wicket.apache.org/news/2016/03/01/cve-2015-5347.html
- http://www.securitytracker.com/id/1035165
- https://issues.apache.org/jira/browse/WICKET-6037
- http://wicket.apache.org/news/2016/03/01/cve-2015-5347.html
- http://www.securitytracker.com/id/1035165
- https://issues.apache.org/jira/browse/WICKET-6037
Get alerted when CVE-2015-5347 or the next vulnerability affects your stack