What’s Vulnerable › Vulnerabilities
CVE-2015-5364
- Severity: high (CVSS 7.8 v2.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 6.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2015-08-31 · updated 2026-06-17
- Weakness: CWE-399
Description
The (1) udp_recvmsg and (2) udpv6_recvmsg functions in the Linux kernel before 4.0.6 do not properly consider yielding a processor, which allows remote attackers to cause a denial of service (system hang) via incorrect checksums within a UDP packet flood.
Affected products
- Canonical Ubuntu Linux: 12.04, 14.04, 15.04
- Debian Linux: 7.0, 8.0
- Linux kernel: before 3.2.70; from 3.3 before 3.4.109; from 3.5 before 3.10.81; from 3.11 before 3.12.44; from 3.13 before 3.14.45; from 3.15 before 3.16.35 — fixed in 3.10.81, 3.12.44, 3.14.45, 3.16.35, 3.18.17, 3.2.70
- RedHat Enterprise Linux Server Aus: 6.5
How to fix
Upgrade to a fixed version: Linux kernel 3.10.81, 3.12.44, 3.14.45, 3.16.35. Check the vendor advisory for mitigations.
References
- http://git.kernel.org/cgit/linux/kernel/git/torvalds/linux.git/commit/?id=beb39db59d14990e401e235faf66a6b9b31240b0
- http://kb.juniper.net/InfoCenter/index?page=content&id=JSA10761
- http://lists.opensuse.org/opensuse-security-announce/2015-07/msg00023.html
- http://lists.opensuse.org/opensuse-security-announce/2015-07/msg00049.html
- http://lists.opensuse.org/opensuse-security-announce/2015-08/msg00011.html
- http://lists.opensuse.org/opensuse-security-announce/2015-09/msg00004.html
- http://lists.opensuse.org/opensuse-security-announce/2015-09/msg00007.html
- http://lists.opensuse.org/opensuse-security-announce/2015-09/msg00008.html
- http://lists.opensuse.org/opensuse-security-announce/2015-09/msg00009.html
- http://lists.opensuse.org/opensuse-security-announce/2015-09/msg00010.html
- http://lists.opensuse.org/opensuse-security-announce/2015-09/msg00011.html
- http://lists.opensuse.org/opensuse-security-announce/2015-09/msg00018.html
Get alerted when CVE-2015-5364 or the next vulnerability affects your stack