What’s Vulnerable › Vulnerabilities
CVE-2015-5467
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.9% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-09-21 · updated 2026-06-17
- Weakness: CWE-22
Description
web\ViewAction in Yii (aka Yii2) 2.x before 2.0.5 allows attackers to execute any local .php file via a relative path in the view parameeter.
Affected products
- yiisoft yii: from 2.0.0 before 2.0.5 — fixed in 2.0.5
How to fix
Upgrade to a fixed version: yiisoft yii 2.0.5. Check the vendor advisory for mitigations.
References
- https://github.com/FriendsOfPHP/security-advisories/blob/master/yiisoft/yii2-dev/CVE-2015-5467.yaml
- https://www.yiiframework.com/news/87/yii-2-0-5-is-released-security-fix
- https://github.com/FriendsOfPHP/security-advisories/blob/master/yiisoft/yii2-dev/CVE-2015-5467.yaml
- https://www.yiiframework.com/news/87/yii-2-0-5-is-released-security-fix
Get alerted when CVE-2015-5467 or the next vulnerability affects your stack