What’s Vulnerable › Vulnerabilities
CVE-2015-5532
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.1% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2017-10-23 · updated 2026-06-17
- Weakness: CWE-79
Description
Multiple cross-site scripting (XSS) vulnerabilities in the Paid Memberships Pro (PMPro) plugin before 1.8.4.3 for WordPress allow remote attackers to inject arbitrary web script or HTML via the (1) s parameter to membershiplevels.php, (2) memberslist.php, or (3) orders.php in adminpages/ or the (4) edit parameter to adminpages/membershiplevels.php.
Affected products
- Paid Memberships Pro: before 1.8.4.3 — fixed in 1.8.4.3
How to fix
Upgrade to a fixed version: Paid Memberships Pro 1.8.4.3. Check the vendor advisory for mitigations.
References
- http://packetstormsecurity.com/files/132812/WordPress-Paid-Memberships-Pro-1.8.4.2-Cross-Site-Scripting.html
- http://www.paidmembershipspro.com/2015/07/pmpro-updates-1-8-4-3-and-1-8-4-4/
- http://www.securityfocus.com/archive/1/536057/100/0/threaded
- https://github.com/strangerstudios/paid-memberships-pro/commit/add03e3ed90e9163e5a46e20e6c371a87ff5a677
- https://wordpress.org/plugins/paid-memberships-pro/#developers
- https://wpvulndb.com/vulnerabilities/8109
- https://www.htbridge.com/advisory/HTB23264
- http://packetstormsecurity.com/files/132812/WordPress-Paid-Memberships-Pro-1.8.4.2-Cross-Site-Scripting.html
- http://www.paidmembershipspro.com/2015/07/pmpro-updates-1-8-4-3-and-1-8-4-4/
- http://www.securityfocus.com/archive/1/536057/100/0/threaded
- https://github.com/strangerstudios/paid-memberships-pro/commit/add03e3ed90e9163e5a46e20e6c371a87ff5a677
- https://wordpress.org/plugins/paid-memberships-pro/#developers
Get alerted when CVE-2015-5532 or the next vulnerability affects your stack